# Access was denied by S3 when using public buckets

**URL:** <https://community.dremio.com/t/access-was-denied-by-s3-when-using-public-buckets/7935>\
**Category:** Uncategorized\
**Created:** [September 6, 2021, 3:13pm UTC](https://community.dremio.com/t/access-was-denied-by-s3-when-using-public-buckets/7935 "2021-09-06T15:13:36Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![jacek](https://avatars.discourse-cdn.com/v4/letter/j/e19adc/32.png) [@jacek](https://community.dremio.com/u/jacek)\
**Post date:** [September 6, 2021, 3:13pm UTC](https://community.dremio.com/t/access-was-denied-by-s3-when-using-public-buckets/7935/1 "2021-09-06T15:13:36Z")

</div>

I created a new S3 bucket, set it as public and allowed list/read ACLs to public.  
I created corresponding new data lake with “No authentication” and I added the bucket into the list of public buckets.  
When I click on bucket in web UI, I get an error.  
In the log I can see:

```auto
2021-09-06 15:00:59,598 [qtp267063122-109] INFO c.d.plugins.s3.store.S3FileSystem - User Error Occurred [ErrorId: 3e89d247-02b6-49a5-9797-b44237aac742] 
com.dremio.common.exceptions.UserException: Access was denied by S3

```

I can’t see what S3 operation is rejected in the Dremio log.

Please, help me to make this (demo) scenario working.
