# Dremio errors on startup

**URL:** https://community.dremio.com/t/dremio-errors-on-startup/642
**Category:** Uncategorized
**Created:** [January 15, 2018, 9:55am UTC](https://community.dremio.com/t/dremio-errors-on-startup/642 "2018-01-15T09:55:15Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![ravi.eze](https://avatars.discourse-cdn.com/v4/letter/r/f04885/32.png) [@ravi.eze](https://community.dremio.com/u/ravi.eze)
#### Post date: [January 15, 2018, 9:55am UTC](https://community.dremio.com/t/dremio-errors-on-startup/642/1 "2018-01-15T09:55:15Z")

</div>

Hi,

I am verymuch interested with Dremio because its the only (java) installation where apache arrow works with MapRDB/ MapRFS/ Parquett files. Apache arrow claims to speeup things by 10x-100x.

After my previous experiment failure now i am trying with vanilla dremio (no mapr variant). I get issues here also. SO this is wha ti did is…

as root user…  
downloaded the tar: dremio-community-1.3.1-201712020438070881-a7af5c8.tar.gz ( i dont want to instal rpm)  
followed the instructions at: [https://docs.dremio.com/deployment/standalone-tarball.html](https://docs.dremio.com/deployment/standalone-tarball.html)  
as per this page: [https://docs.dremio.com/quickstart/linux.html](https://docs.dremio.com/quickstart/linux.html) executed the command: sudo service dremio start ; i get the below error

```
file locks (-x) unlimited
Exception in thread "main" java.lang.NullPointerException: No Cluster Identity found
        at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:226)
        at com.dremio.dac.daemon.DremioDaemon.checkVersion(DremioDaemon.java:115)
        at com.dremio.dac.daemon.DremioDaemon.main(DremioDaemon.java:151)

```

and in server.log i see the below log (no error recordedin server.log)

> ```
> 7af5c8.jar!/, jar:file:/opt/dremio/jars/dremio-extra-plugin-elasticsearch-1.3.1-201712020438070881-a7af5c8.jar!/, jar:file:/opt/dremio/jars/dremio-hbase-plugin-1.3.1-201712020438070881-a7af5c8.jar!/] took 699ms
> 2018-01-15 15:19:11,465 [main] INFO c.d.datastore.LocalKVStoreProvider - Starting LocalKVStoreProvider
> 2018-01-15 15:19:12,493 [main] INFO c.d.datastore.LocalKVStoreProvider - LocalKVStoreProvider is up
> 2018-01-15 15:19:12,494 [main] INFO c.d.datastore.LocalKVStoreProvider - Stopping LocalKVStoreProvider
> 2018-01-15 15:19:12,509 [main] INFO c.d.datastore.LocalKVStoreProvider - Stopped LocalKVStoreProvider
> 
> ```

---

<div class="post-metadata">

### Author: ![ravi.eze](https://avatars.discourse-cdn.com/v4/letter/r/f04885/32.png) [@ravi.eze](https://community.dremio.com/u/ravi.eze)
#### Post date: [January 15, 2018, 1:44pm UTC](https://community.dremio.com/t/dremio-errors-on-startup/642/2 "2018-01-15T13:44:24Z")

</div>

I was able to fix this myself.

The problem was that there was a port bind exception on 31010 and somehow it disappears on restart. Also for some unknown reasons dremio is trying to check for updates of packages which caused the ‘No Cluster identity found’ exception. The below modification into dremio.conf ([dremio-home]/conf/dremio.conf) did the magic

> services: {  
> coordinator.enabled: true,  
> coordinator.client-endpoint.port: 31019,  
> coordinator.auto-upgrade: false,  
> executor.enabled: true  
> }

---

<div class="post-metadata">

### Author: ![yufeldman](https://avatars.discourse-cdn.com/v4/letter/y/c77e96/32.png) [@yufeldman](https://community.dremio.com/u/yufeldman)
#### Post date: [January 15, 2018, 6:27pm UTC](https://community.dremio.com/t/dremio-errors-on-startup/642/3 "2018-01-15T18:27:08Z")

</div>

Thank you for sharing the info. Glad you figured it out
