# Query error in local use idea

**URL:** https://community.dremio.com/t/query-error-in-local-use-idea/12816
**Category:** Uncategorized
**Created:** [February 26, 2025, 1:47pm UTC](https://community.dremio.com/t/query-error-in-local-use-idea/12816 "2025-02-26T13:47:56Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![fuliu](https://avatars.discourse-cdn.com/v4/letter/f/41988e/32.png) [@fuliu](https://community.dremio.com/u/fuliu)
#### Post date: [February 26, 2025, 1:47pm UTC](https://community.dremio.com/t/query-error-in-local-use-idea/12816/1 "2025-02-26T13:47:57Z")

</div>

![截屏2025-02-26 21.42.16](https://us1.discourse-cdn.com/flex020/uploads/dremio/original/2X/e/e0cc35c08fbeacf0b502936e4731e30260dad989.jpeg)  
 ![截屏2025-02-26 21.43.34](https://us1.discourse-cdn.com/flex020/uploads/dremio/original/2X/1/1b38c7e9d177e1684b5c6e5c91e397bb76a14ad8.jpeg)  
When I execute a query I get an error ： Error setting up remote fragment execution

---

<div class="post-metadata">

### Author: ![balaji.ramaswamy](https://sea2.discourse-cdn.com/flex020/user_avatar/community.dremio.com/balaji.ramaswamy/32/843_2.png) [@balaji.ramaswamy](https://community.dremio.com/u/balaji.ramaswamy)
#### Post date: [March 3, 2025, 11:11am UTC](https://community.dremio.com/t/query-error-in-local-use-idea/12816/2 "2025-03-03T11:11:24Z")

</div>

@fuliu This means that when the query started to execute, the first step is to assign work fragments to different executor cores. When you get the above error, it means executor is not available. Are you able to check in the executor logs if the executor was up when the query started?

---

<div class="post-metadata">

### Author: ![fuliu](https://avatars.discourse-cdn.com/v4/letter/f/41988e/32.png) [@fuliu](https://community.dremio.com/u/fuliu)
#### Post date: [March 3, 2025, 1:11pm UTC](https://community.dremio.com/t/query-error-in-local-use-idea/12816/3 "2025-03-03T13:11:18Z")

</div>

@balaji.ramaswamy I added the jvm parameter -Dio.netty.tryReflectionSetAccessible=true, and now I can query the data. How can the executor logs you mentioned be printed on the idea console? I have tried some configurations but they cannot take effect. Can you give me some guidance?

 ![image](https://us1.discourse-cdn.com/flex020/uploads/dremio/original/2X/2/227a51ff558c76df4b66b7247deaeb5fd9afd791.jpeg)  
Attached is the IDEA startup log. You see that no info level log is printed.

---

<div class="post-metadata">

### Author: ![Benny\_Chow](https://sea2.discourse-cdn.com/flex020/user_avatar/community.dremio.com/benny_chow/32/5527_2.png) [@Benny\_Chow](https://community.dremio.com/u/Benny_Chow)
#### Post date: [March 5, 2025, 6:48am UTC](https://community.dremio.com/t/query-error-in-local-use-idea/12816/4 "2025-03-05T06:48:58Z")

</div>

Since you are running Dremio through intelij as a developer, I can share my run configuration which I use for day to day development:

```auto
-Dpaths.local=/Users/bennychow/dev/dremioData/data
-Dpaths.dist="file:///Users/bennychow/dev/dremioData/pdfs"
-Ddremio.log.path=/Users/bennychow/dev/dremioData/log
-Dlogback.configurationFile=/Users/bennychow/dev/dremioData/conf/logback.xml
-Dservices.coordinator.auto-upgrade=true
-Ddremio.telemetry.configfile=/Users/bennychow/dev/dremioData/conf/dremio-telemetry.yaml
-Ddremio_allowTestApis=true
-Ddebug.allowNewerKVStore=true
-Dcom.sun.management.jmxremote.port=1099
-Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.ssl=false
-Dio.netty.tryReflectionSetAccessible=true
-Dservices.coordinator.command-pool.size=20

```

More info here: [Configuring via dremio.conf | Dremio Documentation](https://docs.dremio.com/current/get-started/cluster-deployments/customizing-configuration/dremio-conf)

---

<div class="post-metadata">

### Author: ![fuliu](https://avatars.discourse-cdn.com/v4/letter/f/41988e/32.png) [@fuliu](https://community.dremio.com/u/fuliu)
#### Post date: [March 5, 2025, 8:09am UTC](https://community.dremio.com/t/query-error-in-local-use-idea/12816/5 "2025-03-05T08:09:54Z")

</div>

[logback.xml.zip](https://community.dremio.com/uploads/short-url/5oSgyIe50eZrI6aE5r3pOotMi3G.zip) (1.8 KB)

I used the system’s logbak configuration file, but no log file was generated in the log path. Could you share your configuration file?
