API Unauthorized


I am working on a project with a client that involves using the Dremio API. We are on a very old version of Dremio (4.1.3-202001022113020736-53142377) and will hopefully be upgrading soon.

Using Postman, I was able to login to get the auth token. However, when i call the API to list catalogs, I get a 401. Here is the curl command (with items redacted using variables):

curl --location --request GET 'http://{DREMIO_ORIGIN}/api/v3/catalog' \
--header 'Content-Type: application/json' \
--header 'Authorization: Bearer _dremio{AUTH_TOKEN}'

I tried v2 in the API path thinking we may be so old that there is no v3 and with that I get HTML as a response, which looks to be the About page.

Another observation, which may be expected, is on subsequent calls to login, the token changes. The expiration date is a few days away so I assume that’s expected behavior, but thought it could be an early expiration.


I figured it out. Looks like Postman included the word “Bearer” in front of the token. I removed that and it worked. I am not an expert on HTTP Auth but I suppose Dremio does not support a Bearer token.