Automatically format files into physical datasets doesn't work correctly for standard csv

Hi Team
I’ve try to use
“Automatically format files into physical datasets when users issue queries function” but for standard csv file it never format it correctly

CSV File example:

Always return only one column

I’ve try different files as well with “” and Linux/windows EOL but never get correct automatic formation.

Tested on latest Community edition 24.0.0-202302100528110223-3a169b7c

Is there any specific default CSV format which could work with this function?

@Pawel Automatically format files will assume the below, so if your file format is CSV, it is recommended you do not use this feature as you can always get a different line or field delimiter. Also, have you considered Dremio’s COPY INTO feature to move to Iceberg format?

The issue is that once I test this using csv file witch should be ok with this conf it never works correctly with automatically format (always only one column instead two in my example). But when I use the same csv file with set format process without any changes on GUI is working correctly.
So looks like issue with automatic formatting as couldn’t make it working with any csv version.

Could you check that and give me simple example of working csv file format with this automatically option ?

@Pawel Can you please provide a sample of your file that is not working? Meanwhile I will also test