Dremio does not connect to postgres running on AWS (Marketplace)

Hi, I am using version 4.2.1 of Dremio on AWS, however after finishing the installation I cannot connect to a Postgre DB. The error message is as follows: Failure creating/updating [databasename].

[source-management2] ERROR c.d.e.store.jdbc.JdbcStoragePlugin - Connection is not valid.
java.lang.NullPointerException: null
at com.dremio.exec.store.jdbc.JdbcStoragePlugin.getState(JdbcStoragePlugin.java:360)
at com.dremio.exec.catalog.ManagedStoragePlugin.lambda$refreshState$6(ManagedStoragePlugin.java:822)
at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1604)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

1 Like


Can you please send us a screenshot of the postgres source with the values in it?

Hi. Did you investigate anything about what happened?


Sorry missed this one. We need the server.log to investigate what the failure is. Is this something you can share?


Of course I can. Using the same connection I’m trying to via the aws marketplace, I can connect to a Docker that is running on GCP and I can also run on a Docker locally.

server.log.zip (7,2,KB)

Hello, any updates from what happened?

I tried to connect a Bucker S3 and it worked, Postgre just doesn’t work


You re running into a NPE similar to another community post. Will try to reproduce and get back to you


Also facing this issue with the same exact configuration except my Dremio cluster and RDS are both running in us-west-2. I was very excited to launch Dremio AWS Edition from the marketplace… but unfortunately this has forced me back to my EKS cluster.

Has the dev team been able to reproduce the issue?
Is there an open ticket to fix this issue?

Would love to know what the status is. Happy to share my logs if needed.

Thank you,

@jamesdouglas @cfonseca

We have fixed the NPE and showing the right error in the latest version. So please upgrade and then we can know the real cause of the issue


1 Like