Dremio service not starting

I have installed AWS edition 4.9.1 through marketplace/cloud formation. Everything worked fine until I stopped and started the EC2 coordinator and engine instances. By order:

  1. Dremio service was not automatically started after instance restart.

  2. I started it manually service dremio startand no configuration file was found. I found some dremio.conf.back and moved it to /opt/dremio/conf and tried to start the service.

  3. Another error ocurred related with s3 and it was solved by adding the core-site.xml backed up file to /opt/dremio/conf folder

  4. Now I have a problem ‘Dremio is exiting. Failure while starting services.’ It seems that Zookeeper is trying to run another EC2 instance as preview engine, but previously it was running in the same node as the coordinator. I have tried to set the public IP in the dremio.conf, same error:

    Dremio is exiting. Failure while starting services. java.lang.RuntimeException: Preview engine failed to start at com.dremio.dac.server.AwsConfigurator.startPreviewEngine(AwsConfigurator.java:1633) at com.dremio.aws.provision.EC2Provisioner.start(EC2Provisioner.java:332) at com.dremio.provision.service.ProvisioningServiceImpl.start(ProvisioningServiceImpl.java:151) at com.dremio.service.SingletonRegistry$AbstractServiceReference.start(SingletonRegistry.java:137) at com.dremio.service.ServiceRegistry.start(ServiceRegistry.java:88) at com.dremio.service.SingletonRegistry.start(SingletonRegistry.java:33) at com.dremio.dac.daemon.DACDaemon.startServices(DACDaemon.java:195) at com.dremio.dac.daemon.DACDaemon.init(DACDaemon.java:201) at com.dremio.dac.daemon.DremioDaemon.main(DremioDaemon.java:146) Suppressed: java.lang.NullPointerException at com.dremio.exec.catalog.TableAuthorizerService.close(TableAuthorizerService.java:51) at com.dremio.service.SingletonRegistry$AbstractServiceReference.close(SingletonRegistry.java:130) at com.dremio.common.AutoCloseables.close(AutoCloseables.java:126) at com.dremio.service.ServiceRegistry.close(ServiceRegistry.java:96) at com.dremio.service.SingletonRegistry.close(SingletonRegistry.java:90) at com.dremio.common.AutoCloseables.close(AutoCloseables.java:126) at com.dremio.common.AutoCloseables.close(AutoCloseables.java:76) at com.dremio.dac.daemon.DACDaemon.close(DACDaemon.java:295) at com.dremio.dac.daemon.DremioDaemon.$closeResource(DremioDaemon.java:150) at com.dremio.dac.daemon.DremioDaemon.main(DremioDaemon.java:149)

Am I doing the correct procedure here? Is there a better way to run Dremio after AWS subscription? There´s no information about how to deal with the daemon from aws edition after the marketplace subscription

Here is my Dremio conf:

`services.executor.enabled: false
debug.dist.caching.enabled: true
paths.local: “/var/lib/dremio”
paths.results: “pdfs://”${paths.local}"/data/results"

registration.publish-host: “PUBLIC_IP”
services.coordinator.master.embedded-zookeeper.enabled: false
zookeeper: “PUBLIC_IP:2181”
paths.accelerator = “dremioS3:///dremio-me/dremio/accelerator”
paths.uploads = “dremioS3:///dremio-me/dremio/uploads”
paths.downloads = “dremioS3:///dremio-me/dremio/downloads”
paths.scratch = “dremioS3:///dremio-me/dremio/scratch”`

Also my conf folder seems to be empty when compared with my engine instance (in another machine), so I have executed a mv /mnt/c1/etc/* /opt/dremio/conf/ at the coordinator instance.
Now I have many files and previously I had only dremio.conf and core-site.xml.

Dremio service starts with /opt/dremio/bin/dremio start but when I connect to host at 9047 port it is asking for a new deployment

I have reinstalled AWS Marktplace version, but this time at 4.9.3
Everything goes welll until a instance reboot.
It seems that conf dir is missing after reboot
Maybe something related with EBS disabling volume when the instance reboots.

Problem solved after moving files from /mnt/c1 to /var/dremio/efs (sym link of /opt/dremio/conf)