Error preparing job download on lastest dremio community image


I am running Dremio Lastest version (dated 0605) , The job was running fine, but when I try to export the results to json or parquet,

it says “Error preparing job download.”, Thats quite discouraging I would say, after an hours’ work.

Any hint to to resolve this ?

when I checked the job status for the failed export job.

it says:

IndexOutOfBoundsException: index: 0, length: 4 (expected: range(0, 0))

@marvinwu, can you attach a profile for the failed export job?

Hi Ben,

Here it is, it seems to related to reflection. If I turn off the reflection it works (18.2 KB)

Thanks @marvinwu,

For the dataset tmp."edxNLAllETL.json"; what kind of source is tmp?

tmp is NAS Source map to a local folder on mac.

I tried S3, it has the same problem. if I didn’t enable reflection, it works, once reflection on, the index out of bounds error pop up

Im getting this same error on a Numeric field trying to parse it out into a Long in a spark data frame using the dremio jdbc driver.

I also see the issue after creating a Raw reflection for the field