Error when working with MSSQL

Hello all,

I’m using Dremio 3 (3.0.6-201812082352540436-1f684f9), hooked up to a MSSQL database.

When querying a certain table I run into an error like the one mentioned below:

[e0 - 23c21dd5-23ee-3932-744e-0c51cc380300:frag:0:0] INFO - User Error Occurred [ErrorId: c8596c3f-1f50-4869-aa4b-1152acca1662]

com.dremio.common.exceptions.UserException: A column you queried has a data type that is not currently supported by the JDBC storage plugin. The column’s name was TIMESTAMP and its JDBC data type was BINARY.

This error appears when using any aggregate function, such as MIN or MAX on the “TIMESTAMP” column. I’ve tried adding the JVM option: “-Ddremio.jdbc.mssql.push-collation.disable=true.”, but this was to no avail. Switching between querying the source directly or using a reflection (no matter the type) doesn’t make any difference. Same goes for converting / casting the problematic column and so forth.

Any clues how to solve this? Please note that I cannot make any changes to the MSSQL database, as this is a black box.


HI @rajdee

Can you please send us the entire job profile

Share a Query Profile


Sure thing! Which query would you prefer? Raw data or reflection?

Ok, I’ve downloaded a job profile and gathered some logs. I’d rather not post these files on a public site, can I get them to you in a more safe manner? Email e.g. ?