Error while upgrading Dremio JDBC driver

Hello Team,

While trying to upgrade the Dremio JDBC driver to 19.0.0 version we are getting the following error,

"{\"WFLYCTL0080: Failed services\" => {\"jboss.deployment.unit.\\\"alpha19.war\\\".POST_MODULE\" => \"WFLYSRV0153: Failed to process phase POST_MODULE of deployment \\\"alpha19.war\\\"
    Caused by: java.lang.RuntimeException: WFLYSRV0177: Error getting reflective information for class cdjd.com.codahale.metrics.jetty9.InstrumentedHandler$7 with ClassLoader ModuleClassLoader for Module \\\"deployment.alpha19.war\\\" from Service Module Loader
    Caused by: java.lang.NoClassDefFoundError: Failed to link cdjd/com/codahale/metrics/jetty9/InstrumentedHandler (Module \\\"deployment.alpha19.war\\\" from Service Module Loader): cdjd/org/eclipse/jetty/server/handler/HandlerWrapper\"}}

"

Our system configuration:
Java version “1.8.0_65”
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ 64-Bit Server VM (build 25.65-b01, mixed mode)
If more information is required please revert back on this.

Till version 15.7.0 the error is not there and everything runs smooth but above that we get this error,
So, can you guys suggest a fix for this?

Thank you,
Rohan Bhardwaj.

Hi @ronnie123 ,

Is this for Dremio Software? Is the new driver in this folder as specified in the docs here: Dremio?

~<DREMIO_HOME>/jars/jdbc-driver/

Cindy