How do I turn off debug logging

I’m having a hard time figuring out from the documentation how to turn off debugging. There is a “debug” section but it’s not explained anywhere how to use it. I started a new node and it already has over 100MBs of logging in just a few minutes.

In your conf folder there is a logback file, you can modify the loglevels from there.

For example, you can change it from info to debug by modifying
{dremio.log.level:-info} to {dremio.log.level:-debug}

I think you can set it to trace, debug, info, error, off

I could do it that way. I’ll have a look. Normally I expect to see a config setting that controls the logging level to report.

Update: Well something I don’t understand is going on. I looked at the log configuration and it does indeed default to info. But the log is now up to 8GB of DEBUG level messages. I don’t see dremio.log.level being set as a java option but will try doing that to see if it changes the behavior.

I’m setting this env variable so that the option gets passed to java:


And it has no effect, I’m still seeing tons of DEBUG log messages in server.out

Such as:

16:58:35.566 [qtp1123913519-128-selector-ServerConnectorManager@62832e24/0] DEBUG - Queued change$1@22f3d128

Commenting out all of the log configuration did not change the output. Perhaps another configuration got embedded in one of the jar files?

Ok, it wasn’t finding the logback configuration files. I added “/opt/dremio/conf” to the classpath and the messages have stopped.

1 Like

Thanks for reporting back.