How to set up development environment for dremio-oss with IntelliJ


I tried to set up development environments for dremio-oss with IntelliJ.

  1. mvn clean install -DskipTests
  2. Import source code with pom.xml to IntelliJ

But some unit tests failed. For example, TestHashAgg failed.

java.lang.IllegalArgumentException: resource /com/dremio/exec/expr/fn/impl/gaggr/ relative to com.dremio.exec.expr.fn.impl.gaggr.SumFunctions$NullableFloat4Sum not found.

	at com.dremio.exec.expr.fn.FunctionInitializer.getSourceURL(
	at com.dremio.exec.expr.fn.FunctionInitializer.get(
	at com.dremio.exec.expr.fn.FunctionInitializer.checkInit(
	at com.dremio.exec.expr.fn.FunctionInitializer.getMethod(
	at com.dremio.exec.expr.fn.BaseFunctionHolder.meth(
	at com.dremio.exec.expr.fn.BaseFunctionHolder.meth(
	at com.dremio.exec.expr.fn.AggrFunctionHolder.setup(
	at com.dremio.exec.expr.fn.AggrFunctionHolder.renderStart(
	at com.dremio.exec.expr.EvaluationVisitor$EvalVisitor.visitFunctionHolderExpression(
	at com.dremio.exec.expr.EvaluationVisitor$InnerMethodNester.visitFunctionHolderExpression(
	at com.dremio.exec.expr.EvaluationVisitor$ConstantFilter.visitFunctionHolderExpression(
	at com.dremio.exec.expr.EvaluationVisitor$CSEFilter.visitFunctionHolderExpression(
	at com.dremio.exec.expr.EvaluationVisitor$CSEFilter.visitFunctionHolderExpression(
	at com.dremio.common.expression.FunctionHolderExpression.accept(
	at com.dremio.exec.expr.EvaluationVisitor$EvalVisitor.visitValueVectorWriteExpression(
	at com.dremio.exec.expr.EvaluationVisitor$EvalVisitor.visitUnknown(
	at com.dremio.exec.expr.EvaluationVisitor$InnerMethodNester.visitUnknown(
	at com.dremio.exec.expr.EvaluationVisitor$ConstantFilter.visitUnknown(
	at com.dremio.exec.expr.EvaluationVisitor$CSEFilter.visitUnknown(
	at com.dremio.exec.expr.EvaluationVisitor$CSEFilter.visitUnknown(
	at com.dremio.exec.expr.ValueVectorWriteExpression.accept(
	at com.dremio.exec.expr.EvaluationVisitor.addExpr(
	at com.dremio.exec.expr.ClassGenerator.addExpr(
	at com.dremio.exec.expr.ClassGenerator.addExpr(
	at com.dremio.sabot.op.aggregate.hash.HashAggOperator.setupUpdateAggrValues(
	at com.dremio.sabot.op.aggregate.hash.HashAggOperator.createAggregatorInternal(
	at com.dremio.sabot.op.aggregate.hash.HashAggOperator.setup(
	at com.dremio.sabot.BaseTestOperator.validateSingle(
	at com.dremio.sabot.BaseTestOperator.validateSingle(
	at com.dremio.sabot.BaseTestOperator.validateSingle(
	at com.dremio.sabot.aggregate.hash.TestHashAgg.validateAgg(
	at com.dremio.sabot.aggregate.hash.TestHashAgg.floatWork(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(
	at org.junit.runners.model.FrameworkMethod.invokeExplosively(
	at org.junit.internal.runners.statements.InvokeMethod.evaluate(
	at org.junit.internal.runners.statements.RunBefores.evaluate(
	at org.junit.internal.runners.statements.RunAfters.evaluate(
	at org.junit.rules.TestWatcher$1.evaluate(
	at org.junit.internal.runners.statements.FailOnTimeout$
	at org.junit.internal.runners.statements.FailOnTimeout$

‘’ is in ‘dremio/sabot/kernel/target/generated-sources/fmpp/com/dremio/exec/expr/fn/impl/gaggr’ and directory ‘fmpp’ is set as source folder in IntelliJ. I think that this source expects in both source folder and resource folder because Resources.getResource failed.

Please tell me the instruction of setting up the development environment with IntelliJ.


I’m new here, so bear with me. I’ve got dremio-oss (3.1.9) loaded into intellij 2019.1. Doing mvn (Apache Maven 3.6.0) builds without error. (Java Open Jdk Version: 1.8.0_171)

I’ve done builds from command line (mvn clean install -DskipTests). I run build through intellij with maven with same result.

The only reoccurring problem I’ve had is diagnosing dremio exceptions related to instructions:
mvn compile exec:exec -pl dac/daemon

But it sounds like you are hitting a compile time issue… I guess I would suggest removing intellij from the equation and getting a compile working from mvn directly before introducing intellij into the mix.

Hi Bruce,

Thanks for your reply!! I will try again while referring to your results.

I’ll write up some experiences building this thing on my site and reference them. Looks like there might be some interest looking through the uncategorized questions…

1 Like

Here is a quick write-up of my build procedure for dremio-oss.

Hi Bruce,

Could you please elaborate on how you got dremio-oss loaded into intellij? When I try to load all of it in, intellij creates iml files within each subproject. Consequently the project fails to build.

Can you share the error or problem that you are seeing with the build? As far as I remember, I ran through the intellij help information on maven:

And intellij loaded the project and then started downloading dependent packages in the background (there are tons ~2.2G in my case). Perhaps there is some dependency not getting downloaded?

Sorry you’re having difficulty with this. I have .iml files all over as well but I don’t think it conflicts with an intellij maven build. Also, I can see that the .gitignore lists “*.iml” to ignore so I’m pretty sure that others use intellij to work with Dremio code.

I know I wouldn’t try to work with this code much outside an IDE.

Hi Bruce, thanks for the response. I have attached a screenshot of the error that I see when I try to import this project into intellij.

  1. When the time came to select the content root I went for just the client submodule and selected it. I left others unmarked. I double checked this after having imported the project from Project setting --> modules

  2. When I tried to build, I got lots of errors of the form "Can’t find symbol ". I googled a bit and deleted the .iml files present in the submodule which houses the file that manifested that error.

I must be doing something wrong, so your guidance is really appreciated.

I can’t help you much from what you’ve shared. From what I see, you haven’t built all the sub-modules that are needed to compile the code you are trying to build. This is a very large project with many sub-modules.

Don’t bother with intellij until you get something close to a full build with maven (mvn) from the command line. Review and from a command line do build in the root directory.

mvn clean install -DskipTests

Hi Bruce,

I solved the problem myself. I hadn’t imported the project as a maven project. Recreating with that option helped.

Thanks for the help though.

1 Like