IOException Attemped to open range reader for invalid range 4.0.2

I am running 4.0.2 on AWS EKS. Previously I created tables with CTAS and was able to read them using Dremio. When I did the same thing today I started getting this error when I try to query them. My previous ones also stopped working with the same error. The error is also popping up on reflections. I suspect that it has to do with the shape of the data because the sample data works fine. When I setup the data format it correctly reads the parquet file in the data preview window.

IOException: Attemped to open range reader for invalid range. Requested Range: [4..369814). Valid Ranges: [[33946178..33946207)=com.dremio.parquet.pages.async.SlidingWindowReader@7e6080bc]

I attached the query profile.

Thank you for any insight you can give.

a9ccb9dc-7f0c-4d5e-937b-a65c2b6af6f5.zip (21.2 KB)

I found my issue. The data had a field name of * (asterisk character). Once I removed that field from the query everything worked as expected. It would be good if it either handled that or gave a more descriptive error message.