Issue with Select query only when using Hive metastore to Minio storage

Hi everyone,

I’ve deployed Hive Metastore as a shared tool to save metadata for all the tables in Minio Object storage.
I’ve tried creating tables, inserting data and dropping tables and all seems good so far.
The only issue is when I try to query the data using the same source “Hive metastore” . we I do so I get errors “IllegalStateException: Invalid AWSCredentialsProvider provided:”. I added more properties to the hive 3.x plugin in Dremio, like
but now I’m getting new error:
StsException: The security token included in the request is invalid. (Service: Sts, Status Code: 403,

attached images are my configs in both Dremio and Hive metastore:


  • there are additional confige for Dremio to Minio S3a more than needed. I was trying to check if anything could be the cause of theis issue.
  • Amazon S3 feature works well with Minio.

Would appreciate your kind support :slight_smile:
Best regards
Abdelrahim Ahmad

Hi All,
problem solved:
I’ve added a new property from dremio:

Value has to be set to true.

Just added it if anyone else come to this problem.

@Abdelrahimk Thanks for the update, there is check box that you simply click too, it is source advanced settings, Enable compatibility mode