Postgres query timing out after 10 seconds

Hi everyone,

I was able to successfully connect my Postgres database to my Dremio instance and I can navigate its tables and even preview the tables with no problem.

But when I run a SELECT query on any of the tables and it runs for more than 10 seconds, I get the following exception:

Failure getting source [PostgreSQL].Show more

Any idea on how I can fix this?

I am running Aurora DB.

This is the log from the Dremio console:

2021-02-12 14:53:56,841 [grpc-default-executor-75] INFO - User Error Occurred [ErrorId: 45abd7bf-22d1-4545-85a0-8471d65b7954]
com.dremio.common.exceptions.UserException: Failure getting source [PostgreSQL].
at com.dremio.common.exceptions.UserException$
at org.apache.arrow.flight.FlightService.doGetCustom(
at org.apache.arrow.flight.FlightBindingService$DoGetMethod.invoke(
at org.apache.arrow.flight.FlightBindingService$DoGetMethod.invoke(
at io.grpc.stub.ServerCalls$UnaryServerCallHandler$UnaryServerCallListener.onHalfClose(
at io.grpc.PartialForwardingServerCallListener.onHalfClose(
at io.grpc.ForwardingServerCallListener.onHalfClose(
at io.grpc.ForwardingServerCallListener$SimpleForwardingServerCallListener.onHalfClose(
at io.grpc.util.TransmitStatusRuntimeExceptionInterceptor$1.onHalfClose(
at io.grpc.internal.ServerCallImpl$ServerStreamListenerImpl.halfClosed(
at io.grpc.internal.ServerImpl$JumpToApplicationThreadServerStreamListener$1HalfClosed.runInContext(
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$


What version of Dremio is this? Can you please attach the profile?

Version 13.0.0-202101272034330307-20fb9275

here is the profile (10.4 KB)

Hi guys,

@lfnovo any luck with this?
Im facing the exact same issue when trying to connect to a RDS SQL Server.
Dremio 15.0.0-202103312106020527-0be9c719

We found the issue. By using the ‘preview’, only the master coordinator is required. But when we run a query, the request is sent to the executor.

So it was just the firewall preventing the executor to access the source database. After enabling it worked fine