Problem with query - dremio 1.4.4, ES 6.1.1

I just tried the 1.4.4 release with Elasticsearch 6.1.1
I can do a some queries like:

FROM hn_items 
where "type" is null
limit 10 

but not

FROM hn_items 
where "type" ='story'
limit 10

I get the error “Failure executing Elastic request start search.” I didn’t know if it was the syntax of the string so I tried a few options - nothing works.

Am I formatting my query wrong or is this a bug?

I can do other queries and join using a where clause - but a simple where = “string” isn’t working.

What am I doing wrong?

It seems I can do as a like query
"type" like 'story'
but I don’t think I can should need to.

This query works on ES 2.x and 5.x but may not work on 6.x at this time.


Sorry about that, we are working on adding support for ES6 in a future release.

ok - thanks - Is there an ETA? Many queries do work but this for some reason doesn’t.

Support for Elasticsearch 6.0 is now available in our latest release, Dremio 2.1. More details here.