Timestamp issue in Dremio

Hi Team,

I have a hive table which has timestamp column with milliseconds (2019-02-05 04:34:00.087521) but when accessing this table via Dremio the miliseconds is being truncated to 000 as 2019-02-05 04:34:00.000. How do i retain all the milliseconds in Dremio when accessing this columns. Also is there a way to disable UTC conversion in Dremio.

Raghuraman R

Hi, @raghu_raman_ravishan
You can change data type,
Convert to “Date & Time

ps: something is wrong with uploading picture


Can you provide the schema of the hive table, specifically the column that is seeing the truncation? Internally Dremio converts everything to UTC and there is no way to disable that.


The millisecond truncate needs a code fix, which is in progress. Will keep you posted about the upcoming releases with this fix.