Working With Your First Dataset

Once you know the basics of Dremio, you’re ready to start working with your first dataset. Here we use Amazon S3 to keep things simple.

If you have comments or suggestions, please post below.

See our Resources page for a list of all our Tutorials and other resources:

I followed this tutorial and I get null for all rows except the first. My first row matches the one shown in the image, but otherwise, they are all null. Anyone have thoughts on why that might be?

Did you click preview or run?

I did. Tried it again and got the same results. On macOS. Will try a fresh install on my Ubuntu server later and see if I still get the errors.

@kmbutler, I’m getting the exact same results as you. I’ve checked and re-checked the SQL more times than I care to admit. Tried C/P from the tutorial and retyped the SQL in case there was a hidden character that was messing me up.

This is also on Mac OS and Chrome Version 64.0.3282.167

Did a fresh install solve your problems?

Screenshot for reference:

I just tested this on Ubuntu with Dremio 1.4.7 and it works the same as in the tutorial.

We’ll try and repro on macOS.

Thanks for your patience!

@kelly, if you want to Webex to see what it’s doing on my machine, I’ll be happy to help

FWIW, I’m on 1.4.4 This was the version on the automated download.

Where can I find 1.4.7?

For me this works as expected on macOS 10.13.3 with Dremio 1.2.1 and 1.4.4.

1.4.7 is an internal build. You are using the most recent public build.

I’m puzzled why your experience is different …

What do you get for SELECT COUNT(*)?

Quick update on this:

  1. Tested Dremio 1.4.4 on CentOS 7 and it worked just like the tutorial
  2. Correction: Paring the SQL down, it seems to go wonky on the ORDER BY. If I just do a simple SELECT or COUNT, the results seem fine. Once I add the ORDER BY back in, I start getting the null values. This is back on OSX, btw
    This applies whether I put the ORDER in the SQL or try to SORT in the dropdown of the results set

Also, I just tested in Firefox with the same results. It’s completely repeatable on both browsers