Cannot open file: /opt/dremio/log/server.gc due to Permission denied

Installed Dremio on an ubuntu 18.04 machine.

During tarball install, a lot of things were done manually, but I followed the documentation as well as the quickstart, all the instructions of my installation are there.

Because of this manual install, its possible that all sorts of permission issues are going to occur.

I have already manually created the server.out file and given the whole /opt/dremio directory permission for the dremio user/group to try to make things work.

Given the error server.out gave:

cannot open file: /opt/dremio/log/server.gc due to Permission denied

Any suggestions of what should I try out? I a reinstallation recommended?

In case of a reinstallation how would I delete/purge all the files used so I could have a fresh restart?

Are you seeing this error? On startup?

What user is running the Dremio service?

What are the permissions on /opt/dremio/log/?

on the server.out log file. When I run the service using sudo service dremio start


total 40
drwxrwxr-x  2 dremio dremio  4096 may 20 14:41 .
drwxrwxr-x 10 dremio dremio  4096 may 20 11:40 ..
-rwxrwxr--  1 dremio dremio 30897 may 20 11:47 server.out

When you startup Dremio, from the shell, run ps -ef | grep Dremio. From that output, what user owns the Dremio daemon process?

Also, in dremio-env where have you configured the Dremio logs to write.

# Directory where Dremio logs are written
# Default to $DREMIO_HOME/log

Apologies for any obvious questions. Just trying to get a complete picture here…

sorry, I’m not that familiar with linux processes. This is the output i had:

dremio    8145     1 99 15:47 ?        00:00:07 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java -Djava.util.logging.config.class=org.slf4j.bridge.SLF4JBridgeHandler -Djava.library.path=/opt/dremio/lib -XX:+PrintGCDetails -XX:+PrintGCDateStamps -Xloggc:/opt/dremio/log/server.gc -Ddremio.log.path=/opt/dremio/log -Xmx4096m -XX:MaxDirectMemorySize=8192m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/opt/dremio/log -Dio.netty.maxDirectMemory=0 -DMAPR_IMPALA_RA_THROTTLE -DMAPR_MAX_RA_STREAMS=400 -cp /opt/dremio/conf:/opt/mapr/hadoop/hadoop-2.7.0/etc/hadoop:/opt/dremio/jars/*:/opt/dremio/jars/ext/*:/opt/dremio/jars/3rdparty/* com.dremio.dac.daemon.DremioDaemon
tonio     8228  6106  0 15:47 pts/1    00:00:00 grep --color=auto dremio


BTW, I successfully installed dremio on EC2 instances with yum and it worked properly. Just thought I would try working with it on my ubuntu desktop, but I see that tarball install and manual tweaking is way out of my scope of knowledge.

I suggest having a .deb version to download, or a better documentation on manual install/ubuntu install and run.

Also, I don’t like going to the cryptic html directory you guys have for older version downloads. It is way too hard to find. Would be nicer to have the older versions readily available somewhere near the deploy tab.

Except all that, I love the things dremio provides and your support. I will repost this message in some feedback area of the forum, just thought I’d give you context : ).