Data Source - Amazon S3 Settings - Enable SSL Encryption not working?

I have installed Dremio as a single stand-alone server (using dremio-community-2.0.1-201804132205050000_10b1de0_1.noarch.rpm) and connected to my S3 Bucket as a data source.
The bucket policy requires secured transfer to view the content (files) in the bucket.

“Condition”: {
“Bool”: {
“aws:SecureTransport”: “true”

I have checked the “Enable SSL Encryption” option in the source settings popup window and it doesn’t seem to be working. If I reopen the settings, it is unchecked. When I remove the condition on the S3 bucket policy, I’m able to connect and query the data.

Does the “Enable SSL Encryption” option have a known bug?


By the way, I’m using my credentials and NOT setting the External Buckets .

Does anyone have any feedback for this question?

Is this related to a similar topic Error accessing S3 (can see bucket list but not objects)

It looks like there is a UI bug in 2.0.x where the Enable SSL checkbox isn’t being checked in the UI when you edit a source - however the setting is being saved correctly when you created it.

That makes sense. Thanks for the answer.