Dremio install "No Cluster Identity found" on Centos 7

I am getting this error while starting dremio for the first time. This is running dremio-community-1.3.1-201712020435270019-a7af5c8-mapr on Centos 7 using the tar installation steps. I have tried setting the auto-upgrade setting that was suggested for OSX but it did not make a difference.

tailf log/server.out
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 15059
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited
Exception in thread “main” java.lang.NullPointerException: No Cluster Identity found
at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:226)
at com.dremio.dac.daemon.DremioDaemon.checkVersion(DremioDaemon.java:115)
at com.dremio.dac.daemon.DremioDaemon.main(DremioDaemon.java:151)

Hi @Dragos_Preutu

Can you please send me output of “ps -ef | grep dremio”?

Can you also please attach the server.log?


it is no longer running
ps -ef|grep dremio
root 14596 14530 0 00:01 pts/0 00:00:00 gserver.log.zip (2.5 KB)
rep --color=auto dremio

Can you also provide server.out?

server.out.zip (1009 Bytes)


Can you make sure that the directory /var/lib/dremio/db (or the equivalent if you changed the default configuration) doesn’t exist before starting the server?


removing ‘db’ folder make that error go away
I run into the next issue after that which seems to be permission related. I had to give ‘dremio’ user write privilege to the Hadoop folder where it tries to write cache. Documentation points to mapr user having that privilege instead

2017-12-08 18:44:22,6389 ERROR JniCommon fs/client/fileclient/cc/jni_MapRClient.cc:2172 Thread: 16088 mkdirs failed for /titan/dremio_cache/pdfs/uploads, error 13

Glad you were able fix your problem: dremio is pretty sensible (too much) regarding older installation remains. I’m taking a note for the team to see if we can improve this a bit.

As for the new issue, I would suggest opening a new thread regarding Dremio and MapR cluster, as it seems unrelated to this one.