macOS Sierra startup failure "No Cluster Identity found"

Having trouble starting Dremio on macOS Sierra 10.12.6 with Java 8 (update 144). My server.out log file says this:

Sun Aug 20 15:17:10 PDT 2017 Starting dremio on Pauls-MacBook-Pro.local
core file size          (blocks, -c) 0
data seg size           (kbytes, -d) unlimited
file size               (blocks, -f) unlimited
max locked memory       (kbytes, -l) unlimited
max memory size         (kbytes, -m) unlimited
open files                      (-n) 10240
pipe size            (512 bytes, -p) 1
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) 709
virtual memory          (kbytes, -v) unlimited
Exception in thread "main" java.lang.NullPointerException: No Cluster Identity found
	at com.dremio.dac.cmd.upgrade.Upgrade.upgrade(
	at com.dremio.dac.daemon.DremioDaemon.main(

Any idea how to get up and running? Thanks!

Thanks for reporting Paul!

It looks like we let a bug slip through for our Mac application. We will push in the coming days a fixed version of the app.

Meanwhile you can manually change Dremio configuration to not attempt an upgrade when starting up by modifying /Applications/ Replace the line: true

with: false

That did it. Thanks!


Hi Lauren
I’m still facing this issue even after changing the coordinator parameters.
Ive been trying to install in MapR single node cluster.
[root@mcdhpoc3 bin]# tail -f /opt/dremio/log/server.out
04:53:38.496 [main] DEBUG org.apache.hadoop.conf.Configuration - Loaded org.apache.hadoop.conf.CoreDefaultProperties
04:53:38.504 [main] DEBUG org.apache.hadoop.conf.Configuration - Loaded org.apache.hadoop.yarn.conf.YarnDefaultProperties
04:53:38.512 [main] DEBUG com.dremio.datastore.StoreLoader - Loaded the following StoreCreationFunctions: [class$SupportStoreCreator, class com.dremio.dac.service.datasets.DatasetVersionMutator$VersionStoreCreator, class$AccelerationStoreCreator, class$MaterializationStoreCreator, class$StoragePluginCreator, class com.dremio.service.users.SimpleUserService$UserGroupStoreBuilder, class com.dremio.provision.service.ProvisioningServiceImpl$ProvisioningStoreCreator, class com.dremio.exec.server.options.SystemOptionManager$OptionStoreCreator, class$JobsProfileCreator, class com.dremio.service.namespace.NamespaceServiceImpl$NamespaceStoreCreator, class$CatalogSourceDataCreator, class$JobsStoreCreator, class com.dremio.dac.server.tokens.TokenStoreCreator, class$AccelerationHolderStoreCreator, class com.dremio.service.namespace.NamespaceServiceImpl$DatasetSplitCreator].
04:53:38.512 [main] INFO c.d.datastore.LocalKVStoreProvider - LocalKVStoreProvider is up
04:53:38.513 [main] INFO c.d.datastore.LocalKVStoreProvider - Stopping LocalKVStoreProvider
04:53:38.526 [main] INFO c.d.datastore.LocalKVStoreProvider - Stopped LocalKVStoreProvider
Exception in thread “main” java.lang.NullPointerException: No Cluster Identity found
** at**
** at com.dremio.dac.daemon.DremioDaemon.checkVersion(**
** at com.dremio.dac.daemon.DremioDaemon.main(**

@gvivek this post is specifically for the Dremio application on MacOS. It seems you are using the community tarball for Linux. Do you mind opening a new thread? Please add some details like the version and if it is a fresh install or an upgrade.

Oops Apologies. created a new thread - can you please respond on that?
Topic: “MapR - Dremio Installation”

I am seeing this same error on MacOS with Dremio Community 2.0.5. Dremio will not start up and the Server.out file says:

Exception in thread “main” java.lang.NullPointerException: No Cluster Identity found
at com.dremio.dac.daemon.DremioDaemon.checkVersion(
at com.dremio.dac.daemon.DremioDaemon.main(

I tried adjusting the variable to false as indicated earlier in this thread, but it di not fix the problem. I do not see any other errors or warnings in the server.out file or in the server logs.

@jmorrell Is this your first startup attempt? Upgrade or clean install? Usually if Dremio is failing or is interrupted during its initial startup, it might create an empty db directory missing some information, which in turn will cause next start attempts to fail.

HI Anthony. No it is not my first attempt at starting up. I have had troubles on and off. I had Dremio 2.0.1 on my Mac previously and it was never able to start up properly for the same reason. I deleted the 2.0.1 instance and then installed the 2.0.5 instance. I was hoping the latest release - 2.0.5 would fix the problem. Where would I find the DB directory. I do not see it in the folders. I did find the .conf file in the folders.

Try to see if there’s a db dir located in /Users/<user_name>/Library/Dremio if there is, wipe it

There is no Library folder under /Users//

there is no Library folder anywhere under the Users folders. There is a main Library folder on the hard drive. There is no Dremio directory there.

I just downloaded (1 yr after last post) - and same issue on mac - had to go and change dremio.conf to get dremio to start