Error: DATA_READ ERROR: The JDBC storage plugin failed while trying setup the SQL query

Hi

  1. I installed the 4.1.4 community version of dremio, and from its web UI, created Demo workspace, then used the samples csv file Samples.“samples.dremio.com”.“SF weather 2018-2019.csv” and saved as weather into the Demo workspace, so when clicked on Demo workspace, on the right side panel the weather name showed up, the copied path is Demo.weather.
  2. I installed the apache-drill-1.17.0 and dropped the jdbc file: dremio-jdbc-driver-4.1.4-202001240912140359-a90eb503.jar into the jars/3rdparty folder and jdbc-driver folder.
  3. Started apache drill with ./drill-embedded command, then went to drill web UI, created storage plugin: dremiodemo:
    {
    “type”: “jdbc”,
    “driver”: “com.dremio.jdbc.Driver”,
    “url”: “jdbc:dremio:direct=localhost:41010;schema=Demo”,
    “username”: “admin”,
    “password”: “”,
    “caseInsensitiveTableNames”: true,
    “enabled”: true
    }
    since apache drill is also using 31010, I changed the dremio jdbc port to 41010 in the conf file.
  4. from drill started session, type show databases;
    dremiodemo.demo is listed as one of the schema names,
    then:
    type select * from dremiodemo.demo.weather;
    I got error: Error: DATA_READ ERROR: The JDBC storage plugin failed while trying setup the SQL query.

sql SELECT *

FROM “DREMIO”.“Demo”.“weather”

plugin dremiodemo

Fragment 0:0

in the Dremio server.log file, it showed erro:
Caused by: org.apache.calcite.sql.validate.SqlValidatorException: Table ‘DREMIO.Demo.weather’ not found
Any clues? thanks for help.

@idoor88

We do not support drill as a JDBC client. Does the same work from another JDBC client like DBeaver. If that works then problem is sue to Drill

Thanks
@balaji.ramaswamy

I do not think that is correct statement: not support drill as a JDBC client, since I used the 4.0.4 version of dremio with apache drill 1.14, it worked before, so the new version should support as well

@idoor88

It may definitely work but we have not tested the product with Drill. We do not do any kind of testing with Drill nor actually list as supported JDBC tools in our docs

Dremio Client Connectivity

Thanks
Bali

Thanks
@balaji.ramaswamy