Error querying data on NAS

Hi, added our NAS as datasource. When trying to create a dataset, I select ‘Unknown’ as Format sicne it contains all kinds of documents.
Then when clicking OK, it takes a good while and I get a “Preparing results” dialog.
And finally, I get this :
Table ‘Dropbox.04 Projects’ not found

Dropbox is the name of the Datasource.
04 projects is the subfolder on which I tried to create a dataset

Any idea what could be going on?

A dataset needs to be a single file or directory of files with the same format. Have you tried one of these?

Hi Kelly,

No, I did not.

Does this mean I can’t just add a NAS to Dremio ‘as is’ containing xmls, excels, word,pdf etc…?

Or can I create several datasets based on the same directory but each time with a different file-type?


Met vriendelijke groeten - Meilleures salutations - Mit freundlichem Gruß - Best regards

Chris Ongena

You can certainly “mount” a directory with different file types, but you must instruct Dremio as to the file formatting for each file or a directory of similar files, which will be treated like one large file.

Dremio doesn’t support XML, PDF, Word, PPT. It does support Excel, CSV, JSON, Parquet, and compressed versions of these files.

See more here: