Getting connection error using 'Arrow Flight SQL ODBC Driver' in LINUX machine

Hi All,

I’m trying to integrate the DB connection of Dremio into Informatica Powercenter. I found an infromatica KB article mentioned ‘Dremio is not certified/supported on PowerCenter. ODBC support statement is provided as the user must engage Dremio vendor support directly to obtain third party ODBC drivers and setup through vendor.’

So i tried looking for how to ODBC can engage with Dremio. And i found a setup the ‘Arrow Flight SQL ODBC Driver’ in LINUX machine from the below link :

When testing by running below command ddtestlib …/lib/ in linux terminal, it throws an error :

Load of …/lib/ failed: …/lib/ undefined symbol: krb5_auth_con init

Please let me know how we can resolve this issue, if anyone challenged this earlier.

@samarapalli you are trying to connect to Dremio from Powercenter using flight?

Yes @balaji.ramaswamy , the above issue is faced while using the library file ‘’ , I think this library file having some issue connecting to the Dremio Build
23.1.0-202211250136090978-a79618c7 .
But, If I using the earlier version of the library file arrow-flight-sql-odbc-driver- then it got resolved and connection got succeeded.

I’m facing one more issue, while I’m trying to connect through the ODBC Data Source 64 Bit. I provided the required as shown below, then its throwing an error ‘Flight returned unavailable error…

Can you please help on this how to resolve the issue.

@samarapalli I have requested someone to look into this and they will get back to you this week


Do you have SSL enabled ? If not please ensure the useEncryption option is unchecked in Advanced Tab.

Also could you please provide a screenshot of the Advanced tab ?

We do have a known issue with Dremio 23.1 as per Dremio ( * In some cases, with the Arrow Flight SQL ODBC driver, users were getting an error when testing the connection to Microsoft Excel in the ODBC Administrator on Windows.)

The fix is available in Dremio versions below

  • 23.1.2
  • 24.0.0

Hi @Rajan_Santhanam , thanks for the response.

Yes, I Unchecked the useEncryption option in Advanced tab and getting the error. Here is the attachement.

Hi @Rajan_Santhanam ,

Yes, it worked after installing the Dremio Version 24.0.0

hi @Rajan_Santhanam , @balaji.ramaswamy

Informatica Designer supports only 32-bit ODBC Data Source to Import the tables from Database, but the ArrowFlightSQLODBC driver is supported only 64-bit.

Is there a possible way to configure the ArrowFlightSQLODBCDSN into Informatica Designer ODBC 32-bit (i.e; how to fetch the tables from Dremio space into Informatica Designer)?

Need your suggestion on this.