Getting IOException when querying


I have installed Dremio through kubenetes. I have currently 1 master, 3 executor and 3 zk
However, When I am querying data in s3 it is giving IOEception.

IOException: Mkdirs failed to create /opt/dremio/data/pdfs/results/1f756008-ec91-ab87-94d0-f8d064c1a500.Show more

After further inspection, I found out that 2 of the executors dremio-executor-0 and dremio-executor-1 have these directories created and have some directories with query ids but the dremio-executor-2 have directory structure similar to master and have no directories like that.

And everytime I am querying data on s3 giving same error . So might be all these queries executing on executor-2. Unlike in Mysql data source in that case some times those are failing with same error and sometimes those are successful.

@Ayush.goyal When you query via a JDBC tool like DBeaver or DBVisualizer, results are not written. When you run a query that does not require the 3rd executor (due to parallelism) it seems like it works. Have you found out the reason on why Dremio is unable to create the results folder on dremio-executor-2?

Hi balaji,

I am able to resolve this issue. When I deployed the dremio dremio-executor-2 had different directory structure like master once i forcefully killed it . It respawn with correct configuration.