Group By/Distinct broken?

We have a VDS that fails now since moving to 12.1.0-202101041749050132-55c827cb Community Edition. The query works when we remove GROUP BY or DISTINCT. We have removed all reflections to simplify it and tried DISTINCT vs GROUP BY to dedupe rows again and every time we get the same error.

“IllegalStateException: Received stream completion for 1fdd1814-35e3-9f98-8cb1-0f2f971fa400:1:3 from 2:61 before fragment executor started. Show more”

Any ideas? Can we dedupe another way? Maybe via reflection? We tried to create an aggregate reflection and it fails with a similar error.

This particular VDS has been solid for five months with no mods. It broke when we upgraded to 12.1 recently.

Thank you


Can you please send us the profile so we can look at the full stack?

Thank you for responding. We found that if I removed the group by or distinct or with… from a query it would stop erroring. Further investigation revealed instability in general and we were getting executor errors. So we are working with the infrastructure team to resolve those issues and increase space/capacity. Those issues likely caused the issues with group by.