Hive source - Failure to configure

When trying to add “Hive source” facing the below issue

Failure while configuring source [mapr_hive]

hive-site.xml does contain the metastore entry as well. can you please let me know if i am missing somthing , thanks and appreciate all your assistance.

Hi @mmmkrish

Is this on a MapR platform? Have you installed Dremio on MapR?

Can we please have the server.log?


Thanks for your mail Balaji…

It is MapR platform and installed Dremio on MapR. Enclosed Dremio server.log file.

Please let me know if any questions, appreciate all your support. thanks! (5.3 KB)

Hi @mmmkrish

It looks like the logfile is from a different time than when the error actually happened. I do not see this error anywhere in the log file. Can you please add the source again, let it hit the error again and then upload server.log?


Hi Balaji,

Sorry , i did not notice.

server.log file is not being updated , last update was 2 days ago, can you please let me know any other file you are looking for ?

Dremio service was not running. so started and tried to add hive source, below were the files created.

Apr 30 03:15 server.gc
Apr 30 03:21 server.out
03:22 access.log
Apr 30 03:26 archive (Directory)

Hi @mmmkrish

Are you using sysytemctl. Are your messages going to standard out? Can you use journal commands to get the server.log entries for the Dremio service


Hi Balaji, while adding hive source , enable SASL has been set as “true” hive-site.xml.

Now the other issue is unable to access dataset.below is the issue , can you please advise.

“Access denied reading dataset”


Sorry for not clear, Hive source was success.

while adding Hive source, Enabled “SASL” since it is been set as true in hive-site.xml

I would need the full error to further trouble shoot, Try this

Copy the table name and click new query and type

select * from and then hit run

It will error out, send us the profile and server.log

Dremio Logs
How To Share A Query Profile



Hi Balaji, My bad , i initially Enabled “SASL” and missed out to provide the details in “specify the Hive Kerberos Principal”

After checking with our team , MapR cluster is not Kerberos.

After setting " false" to metastore SASL in hive-site.xml , i am able to access to Hive dataset,

Thanks and appreciate all your time and response.