How to access a public S3 bucket through corporate firewall

Tried testing the public bucket…

It shows up in Sources, but it comes up empty. The error message is below…

How do I add a HTTP_PROXY setting into the Dremio configuration to get through the corporate firewall?

Caused by: org.apache.http.conn.ConnectTimeoutException: Connect to [] failed: connect timed out
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect( ~[httpclient-4.5.2.jar:4.5.2]
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect( ~[httpclient-4.5.2.jar:4.5.2]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_121]

Hello @david.lee,

Dremio can be configured to run with additional JVM flags. You can use this property to set the http.proxyHost and http.proxyPort options.

From your installation, go to /conf and edit the dremio-env file.

At the bottom of this file is a DREMIO_JAVA_EXTRA_OPTS variable which is commented out with the # character at the front. Uncomment this, and add -Dhttp.proxyHost=[your proxy host] and -Dhttp.proxyPort=[your proxy port]

Ok this worked after some tweeking…

DREMIO_JAVA_EXTRA_OPTS="-Dhttp.proxyHost=[proxy host] -Dhttp.proxyPort=[port]"

Perfect! Thanks for the update.

I did exactly what @david.lee suggested, but I am seeing the following error:

Unable to execute HTTP request: Connect to [] failed: Connection refused: connect

@jduong could this be caused by something other than the proxy?