New schema found and recorded

Hi ,
I made a virtual dataset with dropping some unwanted columns and made some inner joins with three nested queries. I can preview and save the dataset but while I run the query am getting the following error.
I couldn’t able to visualize this dataset in Tableau.

New schema found and recorded. Please reattempt the query. Multiple attempts may be necessary to fully learn the schema.

I tried multiple attempts of Run as mentioned in the error but not works. Please give some suggestion.

What data sources are you connecting to?

It might be helpful to share your query profile. Instructions here: (69.7 KB)

Hi Kelly,

Please find attached the query profile. Still I am facing the same issue

Can anyone help me to sort out this issue ?


Dremio will learn schema for a dataset/query 10 times before stopping and asking you to re-run the query to continue learning the schema.

The profile is for the older 1.0.8 version, can you try in 1.1.0 and see if this still happens?