Schema element "$_dremio_$_update_$::int64"


I successfully imported one Excel-file but cannot run “SELECT count(*)” on it.
I am getting the following error :

SCHEMA_CHANGE ERROR: New schema found and recorded. Please reattempt the query. Multiple attempts may be necessary to fully learn the schema.

In job profile I see that Dremio found to schemas with the only differens in field
schema element “_dremio_update$::int64”.

Original Schema schema(Auftraggeber::varchar, … Bestelldat::timestamp, _dremio_update$::int64)
New Schema schema(Auftraggeber::varchar, Bestelldat::timestamp)

I cannot figure out where comes this “_dremio_update$” field in the schema from
and how to fix the problem).

@ennpet, try running the following query on the dataset:
ALTER PDS <your dataset here> REFRESH METADATA

Also, can you attach the job profile?

Hello Ben,

REFRESH METADATA seems not to help.
Still the same error.


Best regards


  1. Is it possible for you to share that excel file?
  2. Have you tried removing the formatting for this dataset and then re-applying it?

I added this file over import button and therefor cannot remove format.
I reduced the file to only one datarow and the error persists.
This file I can share:!AkcCdpR1_vN7gfdaTTt_7LVKrj8l2w

actually, looks like the problem is only with “SELECT COUNT(*) FROM”.
“SELECT * FROM”. works.

Hi, I added onedrive link to th excel file and profile,
but my antwort was hidden. I didn’t find in the tutorial how I could share
these files in the chat. Can you give me instructions?

Try sending the profile to me

@ben May I know if this issue has been resolved, because I am facing the exact same issue even after refreshing the metadata


This is a known issue that have an Engineering bug filed. Once we fix this issue, the release notes will have an update


Thanks @balaji.ramaswamy