Permissions error on copied VDS

Dremio EE 16

I have a user who created a VDS in her personal space, then did a Save As and saved it to a public space with a different name. Another person is unable to open the VDS in the public space for editing. He gets a “Something went wrong” message with this detail:
User does not have access to [@<<original user’s ID>>,<<original VDS name>>]

The error does not appear in the job log, or in the server log. The VDS’s SQL does not reference any other VDS, only PDSs that the second user has access to. I created a new VDS with the same SQL, and he was able to edit that VDS. It seems that the problem VDS has some reference to the original query, but I can’t find it.

Is there any reason why copying a VDS via “save as” would retain a reference to the original VDS?

@Joe

Wondering if you check the specific privileges set on [@<<original user’s ID>>,<<original VDS name>>]?

Hi, Bali. It’s a personal space, so no user-defined permissions, right?

@Joe You should see privileges tab on the uploaded PDS, I do see privileges on VDS saved in Home space

Oh, I see what you mean. The Privileges page for the PDS with the problem is empty.

@Joe Were you able to fix the privileges and did that help?

No, the privileges page for that PDS is empty. Are you suggesting I should add permissions here?

@Joe Can you please provide a screenshot?

There’s not much to see, but sure.

@Joe Can you try and explicitly add select to all users and retry (Sorry about the delay in response, was OOO)

Tried that - same error.

@Joe

if the original VDS is not from the user’s personal space but from a public space, this problem does not happen right?

@Joe

was able to reproduce the behavior. Let me see if this is a bug or designed to work this way