Reflected data sources not chosen?


#1

I have a view that does not complete. All of the data sources used by the view have reflections but when I look at the Acceleration tab in the Jobs utility it shows each of the data sources as either “Too Expensive” or “Did not cover Query”. Can you explain what this means and what we can do to fix it?


#2

Hi @summersmd

Each of the reflection matching issues are unique. It would be great if you can pass on couple of profiles for the ones that are not getting picked up

Thanks
@balaji.ramaswamy


#3

Balaji,

I’m not sure if this is what you’re looking for but I ran queries against 2 of the data sources that are used in the query in questions and have attached the profiles here. The profile that starts with ‘fa’ is the profile for the query
that uses the reflected data sources.

Thanks.

2dbaa5c3-48c4-4c05-9947-acae9975c85b.zip (34.5 KB)

817944c1-7162-4d60-aa52-f7a6c5ad271e.zip (19.9 KB)

fa432e5a-79a3-40d1-9b11-fa18e6a9b966.zip (213 KB)


#4

Hi @summersmd

I did look at the profile starting with ‘fa’ . I see there are 4 RAW reflections that match but not chosen. There are couple of reasons why reflections would match but not get picked (not get chosen)

  1. Costing: The cost of going back to the dataset is less than than the cost of using the reflection. Now we could be wrong sometimes and would require deeper analysis. In order for us to look at this we need the profile again after you have enabled “planner.verbose_profile” via the support key.

  2. We hit an exception during substitution. Can you please send us the server.log?

Thanks
@balaji.ramaswamy


Reflection Too Expensive