Xlsx files throwing schema change error for count operation

Hi,

I have been trying to work on xlsx files and have been getting “SCHEMA_CHANGE ERROR: New schema found. Please reattempt the query. Multiple attempts may be necessary to fully learn the schema”. This happens while trying to do a normal “SELECT COUNT(*) FROM DATASET_NAME” or any aggregate operation." I can see that dremio has tried 10 schema attempts but it keeps throwing me the error on all xlsx files.

Could you please help.

Hello @reshma.cs

Is the file is getting updated/modified continuously ? Or else it’s an uploaded file in Dremio?

If it’s an uploaded file, is it possible to share the file? and also what is the Dremio version?

Thanks
@Rakesh_Malugu

Hi @Rakesh_Malugu,

Thanks for responding. No, the file isnt getting updated. It is an uploaded file. But this happens for any xlsx file I upload i.e any dummy xlsx file for that matter.

Also, had realised that dremio allows only upto 10 MB for xlsx files. Hence tried a different approach to use CSV instead. But it would be great if dremio increases the xlsx file size and figures out why count keeps throwing this error.

Thanks,
Reshma