Unable to download sample data set from Amazon S3

I’m running Dremio inside a Docker container on SUSE Leap. When downloading the sample data set in the Dremio admin UI I get the following error message (I had to clip the stack trace as otherwise this post gets blocked by Dremio’s Akismet spam filter). All proxies have been set correctly and I can curl the source URL (samples.dremio.com.s3.amazonaws.com) successfully from both within the container and Leap. Any ideas what’s going on?

2019-11-01 08:54:33,618 [qtp68022051-88] ERROR c.d.d.server.GenericExceptionMapper - Unexpected exception when processing GET : com.amazonaws.SdkClientException: Unable to execute HTTP request: samples.dremio.com.s3.amazonaws.com
com.amazonaws.SdkClientException: Unable to execute HTTP request: samples.dremio.com.s3.amazonaws.com
        at com.amazonaws.http.AmazonHttpClient$RequestExecutor.handleRetryableException(AmazonHttpClient.java:1116) ~[aws-java-sdk-core-1.11.375.jar:na]
        at com.amazonaws.http.AmazonHttpClient$RequestExecutor.executeHelper(AmazonHttpClient.java:1066) ~[aws-java-sdk-core-1.11.375.jar:na]
        at com.amazonaws.http.AmazonHttpClient$RequestExecutor.doExecute(AmazonHttpClient.java:743) ~[aws-java-sdk-core-1.11.375.jar:na]
        at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:683) [jetty-util-9.4.15.v20190215.jar:9.4.15.v20190215]
        at java.lang.Thread.run(Thread.java:748) [na:1.8.0_222]
Caused by: java.net.UnknownHostException: samples.dremio.com.s3.amazonaws.com
        at java.net.InetAddress.getAllByName0(InetAddress.java:1281) ~[na:1.8.0_222]
        at java.net.InetAddress.getAllByName(InetAddress.java:1193) ~[na:1.8.0_222]
        at java.net.InetAddress.getAllByName(InetAddress.java:1127) ~[na:1.8.0_222]
        at com.amazonaws.SystemDefaultDnsResolver.resolve(SystemDefaultDnsResolver.java:27) ~[aws-java-sdk-core-1.11.375.jar:na]


Are you able to query this dataset?

Hi @balaji.ramaswamy,

I can’t open the dataset. I’ve tried to follow the tutorial for working with the first dataset. While I can add the sample data set to the Sources, I cannot access the contents. Here are the steps:

  1. I added the sample source which worked fine:


  1. But then when I click on the source name (samples.dremio.com) the error message appears:


Certainly looks like you are unable to hit the source. From the coordinator, are you able to use aws s3 cli and read a file in the bucket?