Upgrade 2.1 Issues


1 Coordinator and 3 Workers
Upgrade path 2.0.5 to 2.1
Chrome Browser

Issue 1 - JDBC storage plugin filed while trying setup the SQL Query
After upgrading I am getting “The JDBC storage plugin failed while trying setup the SQL Query”. This was not an issue before the upgrade.

Data Source SQL Server

Issue 2 - All Reflections Gone
I am in the process of recreating all reflections as they seem completely gone, what am I missing?

Interesting enough my queries seem to run fast but there is no visual acceleration indicator (nothing shown under the jobs section and the GUI shows no reflections on my views)

Issue 3 - Node Activity Page Flickering
the Node Activity page seems to be broken (visually it flickers a lot) .

Issue 4 - Opening a query takes more time to load and preview
On the previous version I was able to click and view a query or click and edit a query, this process was quick fast. Now, this process takes up to 15 seconds (elapse time).


Im facing similar issues after downloading 2.1.4 and starting fresh. I tried in a single node. It does not show up node status and whien tried to connect to elastic though it connects the queries never runs even in preview mode.

Is 2.1.4 version stable one ?

@akikax @sambitdixit Sorry for the troubles. Did both you follow the upgrade instructions - https://docs.dremio.com/advanced-administration/upgrade.html ?

If yes and issues still persist, can you share your server.log & server.out? Were there any direct errors when you ran the upgrade script?

Would either of you likely be using CentOS 6?

Lastly, for the reflection issue, can you share the output of for the reflections issue of select * from sys.reflections?

@anthony We have tried a fresh install of version 2.1.4 in a single node and still facing the same problem. The version seems to be not stable

@kranthikiran01 what are the issues you are facing with 2.1.4? Can you share any of the information I requested in post above?

These are the relavant lines in the log we have found when we hit elasticsearch query
2018-09-17 02:58:40,209 [FABRIC-rpc-event-queue] INFO c.d.s.e.rpc.CoordToExecHandlerImpl - Received remote fragment start instruction for 2460af5f-c9f2-2e66-a752-08550bdcae00:0:0
2018-09-17 02:58:40,212 [FABRIC-rpc-event-queue] INFO c.d.s.e.rpc.CoordToExecHandlerImpl - Received remote fragment start instruction for 2460af5f-c9f2-2e66-a752-08550bdcae00:1:10

@kranthikiran01 can you share a query profile? Also, would you happen to be on a variant of CentOS 6?

@anthony I cant share the query profile, the file uploads are restricted.

We are running RHEL6.4