Windows dremio connection with hortonworks hive

Hi Team,

We are able to connect to hive and see the table list on dremio dashboard, however could not view the data in the table.
We have uploaded the error screenshot of the table that we are trying to view.

Unfortunately it doesn’t seem like the attachment was successful. Can you reattach the screenshot along with the server logs files?

Also, it may be worth attempting to linking/copying the Hadoop XML files (core-site, hive-site, hdfs-site) to our conf dir (e.g. /opt/dremio/conf) and try again. It could also possibly be a permission issue.

Hi Anthony,
Thanks for your response. I am reattaching the error screenshot and would like you let you know that we gave it a try after copying the xml files mentioned by you. However the issue stays.
I would like to tell you more on what all we tried:

  1. we tried installing dremio on windows and dremio was up and we faced the above mentioned issue after connecting to mysql, wherein we were unable to view the data of the tables. Attached error screenshot.
  2. we installed dremio on centos 6.5, the installtion got complete but the dremio service itself is not running. Attached log screenshot.

Please help.

  1. For your first screenshot, sharing a query profile would help. I am going to guess there is a permission error. The default Dremio service acct user dremio needs permission to read the table.
  2. For your second screenshot, it seems like there is already a ZK instance installed on the same node so we are unable to bind ours. Can you talk a little bit more about the environment and node? We require ZK to run but can always use an existing ZK instance if you have one up and running -

Hi Anthony,

Thanks for your response.

  1. We were able to resolve the error after seeing the actual error in the query profile section. However now we are getting another error to which I am attaching you the query profile. The error says that bbiadmin(windows admin user) is not allowed to impersonate admin(dremio admin user). Attached query profile.

  2. We have installed hortonworks on centos 6.5 on our single node cluster(cdhpoc3). We tried installing dremio on this cluster. Since we already had zookeeper running on 2181 port, we added external zookeeper setting in dremio.conf as mentioned by you. However we are still facing the same error. Attaching the dremio.conf screenshot.

Please help. (3.34 KB)