Cannot Create Artic-Enabled Project

Hi, I am following

Using AWS Access Key as credentials I am getting the following error: “UNKNOWN: Unable to marshall request to JSON: Bucket cannot be empty”

Using IAM role + profile ARN (DremioIAMProjectDataAccessRole) I am getting: “Check credentials are valid and Dremio has permissions to access the project store.”

When clicking “Test”.

What I am not sure is if I am supposed to create a new S3 bucket as instructed here: Dremio. The “getting-started/arctic-set-up/” link above doesnt say I have to.

Hi daniel, Thank you for submitting to the community. This error indicates the path may be incorrect.

For information about identifying the URL for your S3 bucket, see

Also, which region are you using for your S3 bucket?

thank you @tgavin, I followed this guide. I tried “//dremio-nessie”, “/dremio-nessie” and “s3://dremio-nessie” as bucket path. Always same error as above.

Dremio cloud is in us-west-2 (oregon), the s3 bucket “dremio-nessie” I created is in that region as well.

Do I have to create a new bucket for a new Arctic-Enabled project or can I reuse the bucket created for the default project when I provisioned Dremio Cloud?

The docs seem to contradict each other here. says nothing about creating a new bucket, but says I need a new s3 bucket.

ok, got it to work. the trick is to simply use “dremio-nessie” as bucket path. no “/”, no “s3://”, nothing.

That looks like it. I did the same test and noticed the same thing.

This works for the S3 bucket “Project Store” field:

This does not work (results in same error):

It looks like the example in the docs shows the “/” – we’ll get that fixed.

1 Like