CSV Import - Decimal point error

When I import CSV file the Integer and Float fields are not reconized. I can´t convert to INT or FLOAT inside Dremio too. I try to replace “.” with “,”. The same result.

Something related to char encoding?

1 Like

Ok. I founded the problem. The SAP BW export INT and FLOAT + " " (blank space) before the separator “;”

If I understand correctly, your field had a whitespace character at the start of each value in the column? We show certain hidden characters in the preview (such as newline chars) but we are not treating whitespace at the start/end as hidden. I have opened an internal ticket for that as that can be quite frustrating.

I have the same problem. Can I specify any Localization setting for import/transformation file?

@bisware What is your file format? CSV?

Yes, CSV in Italian format

@bisware Is the data confidential, any chance you can share a sample CSV?

Sure, here is the flat file.

Piano.zip (4,1 KB)

@bisware I am able to convert column ““Numero rata”” to FLOAT using CAST but not the columns like TotaleRata, is it possible to try without the comma in the values?

Like use 5085425179 instead of 508,5425179

Maybe no, because the Italian format use “point” for thousands separator and “comma” for decimal separator.