CTAS produce error message v21.2.0

Hi community,

When I tried to CTAS a table onto an HDFS datasource from an external datasource, I got the following error message. I’m using v21.2.0. dremio.iceberg.enabled is already enabled.


Kindly send us the Job profile of the above failed query, if no profile, run any other query and send the job profile. Also what happens if you remove the “type=>iceberg”? Does it gets created in PARQUET?

I have the exact same issue on 21.2. When I create the table without "STORE AS (type=>‘iceberg’) " it will successfully create a parquet file.

Do you have distributed storage configured?
Also, what is the default CTAS format setting on the source?

I am using the default dremio.conf file so the distributed path is commented out.

I tried it again but with the distributed file settings set to
dist: “file://”${paths.local}“/pdfs”
but I still get the same error message

Hi @sgoldsmith,

Try going to settings → Support. Under “Support keys”, type dremio.iceberg.ctas.enabled (without quotes). Ensure that this setting is set to TRUE. Let me know if this resolves the issue!

That worked! I had dremio.iceberg.enabled set to true but not dremio.iceberg.ctas.enabled.

I did not see that support key listed anywhere in the documentation.

DML functionality was released in limited Preview mode in 21.x and we strongly advise you to move to at least 22.x (better 23.x) to get all the goodies that we’ve produced.

Glad to hear! Additionally, If you upgrade to v22.x (or later), dremio.icebeg.ctas.enabled will be true by default with full functionality. You will not need to worry about modifying this support key in release 22.x or later.