Data lake shows as empty?

Even though there are multiple data sets and folders within.

But going to the address manually seem to work,

but it is a hacky workaround. Does anyone have any ideas on how to fix this?

It worked until our server went out of space. After cleaning folders not related to Dremio (/tmp), and restarting dremio, we have had this problem.

Have tried to restart dremio, dremio-admin clean etc, but no no success.

@nrlund What do you mean by “going to the address manually”?

Sorry for being unclear Balaji.

If we only click on the Data Lake (Analytics storage - which is an Azure storage account) - we previously saw all the contents. Not it shows up as ‘No Items’

But I found out with some tinkering if we write manually the url with ‘folder’ and the container present, I can see the content.

I have tried to remove the Data Lake and re-add it, but still the same problem.

@nrlund When it was showing empty, was StorageV1 or StorageV2 selected?

It has always been set up as V2

@nrlund Can you please send us the logs from the coordinator?

Sent you the server.log in a PM - maybe related to this warning message?

2021-05-24 00:00:55,890 [source-management69] WARN  c.d.p.a.AzureAsyncContainerProvider - Empty response while reading azure containers Unrecognized field "DefaultEncryptionScope" (class$DFSContainerIterator$FileSystemStub), not marked as ignorable (one known property: "name"])
 at [Source: (byte[])"{"filesystems":[{"DefaultEncryptionScope":"$account-encryption-key","DenyEncryptionScopeOverride":"false","etag":"0x8D8EDD138EC1B7D","lastModified":"Tue, 23 Mar 2021 07:56:53 GMT","name":"stanalytics-curated"},{"DefaultEncryptionScope":"$account-encryption-key","DenyEncryptionScopeOverride":"false","etag":"0x8D89B91DBB402A7","lastModified":"Tue, 08 Dec 2020 15:56:43 GMT","name":"stanalytics-raw"},{"DefaultEncryptionScope":"$account-encryption-key","DenyEncryptionScopeOverride":"false","etag":"0x"[truncated 97 bytes]; line: 1, column: 44] (through reference chain:$DFSContainerIterator$FileSystemListStub["filesystems"]->java.util.ArrayList[0]->$DFSContainerIterator$FileSystemStub["DefaultEncryptionScope"])

@nrlund What version Dremio is this? This looks like an issue we fixed in 15.5

15.5? I use community-server edition


which seems to be the newest at
Index of community-server/ (

Is the versions above 11 released elsewhere?

Sorry Balaji, I thought I was on the latest version

I found the latest version

it will probably work, so let us close this. I will open a new topic if it does not

@nrlund Kindly validate if this problem exists in the latest version and report back if still an issue

Bug has been fixed in the 15.7 version! Works like a charm

Thanks for the update @nrlund