Default user for K8s installation

Hi. I am having issues running Dremio with Kubernetes using the Helm chart found here, I’m using the latest image which is currently 4.8 (also tried with 4.7.3). All pods are up and the logs look good, I can even access the UI. However, the initial setup screen does not appear, only the login page asking for username and password. I attempted to use demio-admin CLI tool to reset the admin password but there does not seem to be any default users.

I have seen others with the issue on non-k8s installations and the recommendation appears to be to remove the /data dir. However, this is not possible with the K8s deployment as a volume is mounted there. I’ve tried deleting the contents of the dir but have the same issue described above.

I have also tried running the setup process locally on my workstation and copying the resulting /data/db dir to the pod, however, RockDB is unhappy with this approach :frowning:

I reset the statefulsets and pvcs several times hoping it was some strange timing issue, but no luck.

Any help is greatly appreciated.


I sorted it out. I had to port-forward into the master pod. I was trying to access via the LB. It appears the setup will only occur if connection is from localhost?

@jlong, the first user would be the admin user. Are you saying that this is not what you experienced?

Hey @ben, thanks for the response.

I was initially trying to connect via the Load Balancer that is created. When doing so, even though it was a brand new cluster, I was only presented with the standard login screen. There was no welcome page to create the initial admin user, which is what I experienced when testing locally.

However, I found that if I port-forwarded to the master pod:

kubectl port-forward pods/dremio-master-0 9047:9047 31010:31010 -n dev-dremio

And then visited the the web UI using http://localhost:9047, the welcome screen appeared and I was able to create the initial user as expected. I assume there is a check that only a connection from localhost is allowed to create the initial user?

So on a completely new installation, without configuring any kind of external authentication (LDAP for example), if you try to connect to the UI on the external IP of the dremio-client service, you do not see the EULA screen or the create first user screen, correct?


I am using an Amazon Network Load Balancer and Traefik as my ingress provider. The route basically looks like this:

AWS NLB - Traefik - K8s service (dremio-client) - Pod (dremio-master-0)