Deleting or editing a source


I’m stuck in this window.
Apparently my connection is mall configured, but I’m not able to edit it, nor do I see a way to delete the source and start from scratch.

Hi Paul,

did you try to go on “Sources” view ? You can reach it by clicking on Sources on the left of screen. At this point you may be able to edit concerned source using the wheel button.
Is it working ?
To create the same source from scratch I think you may have to specify a different name.

No, I directly get an error message.

Something went wrong
source CBB at /source/CBB not found. Reason: null

Hi Paul, sorry to hear you are experiencing this issue. I just want to confirm - by unable to edit, do you mean that there is an error shown if you click the gear button for the source? Can you upload a screenshot of that?

I’d also like to try to reproduce myself. Can you provide the following information:

  • what kind of source is this? (Elasticsearch, Mongo, S3, …)
  • which configuration options were used to set it up? (doesn’t have to be the exact values, just the names of the options used)
  • did this source work when it was initially created, and later stop working?


To access a list of your sources, click the “Sources” link on the bottom left:

Now you should see a list of all your sources on the right. If you hover over one of your sources you will see a gear icon on the far right:

Click the gear, and you should now be able to delete this source:

Hi Kelly,

This works only if you have a ‘green’ source. I have multiple ‘red’ sources. Due to a bad config, but I’m not able to edit nor to delete.

See screencast

Procedure I follow to get a bad resource which I cannot delete.

Hi Paul,

This is a known issue, that I hope we will resolve in our next release.

Here’s a workaround, though: you can delete the misconfigured sources from the list of all sources. Click on the “Sources” link that’s on the left side of your screen, below “Test”, above “CBS”. That takes you to a list of all the sources. Hover your mouse over the bad source(s), and the ‘action’ column will show a gear icon. “Remove source” is the bottom option in the context menu that pops up once you click the gear icon.

Indeed, back to a clean state.

Many thanks.

Hi Paul,

The 1.2.1 release (downloadable here) resolves this problem.


Will check.

Kind Regards,
Paul Hermans