Dremio-admin doesn't work to reset admin password

I installed Dremio quite a while back and then removed it, and now I’m trying it again. I can start Dremio but it seems to assume I already have an admin user, but if I ever created one I can’t remember the password.

I tried using the dremio-admin command, but it just stalls

./dremio-admin -u george -p <PASS>

just runs with no output and never finishes unless I ctrl-c.

I also tried doing

cd ~/Library/Dremio/data/pdfs/uploads/_uploads
ls -ltrh

As recommended in another thread, but that produces no results.

I’m running on MacOS on a 2015 macbook pro.

Is it possible to completely wipe Dremio off my system and start from scratch? I don’t need to preserve any data…I just need to get access.


Hi George,

If you delete the metadata directory you will be able to perform a fresh installation. The location varies by OS, for example on macOS it is: ~/Library/Dremio


Thanks for the reply! I tried deleting that directory and now Dremio won’t start (I reinstalled from the .dmg). It just says “starting…” and then “not running”.

I’ve attached the log file.

Any advice from here?

Seems like your log wasn’t successfully attached to your message. Can you reattach & resend please?

Here’s a zip file of the log (the forum won’t accept a non-zipped version.) Please let me know if this is not the right file.

server.log.zip (1.6 KB)

Can you send server.out as well please?

Here you go! server.out.zip (587 Bytes)

Thanks. I believe the issue is bad metadata. If Dremio failed or is interrupted during its initial startup, next start attempts will fail too. Can you confirm ~/Library/Dremio is completely empty?

I had previously moved the entire folder to a backup location and let Dremio recreate it. I just now tried rm -rf’ing all of the contents (with dremio closed) to make sure that folder is completely empty and then reopened Dremio. I got the same starting -> not running flow.