Dremio community edition in aks

I tried to deploy dremio in aks.I have used a VM B4ms ,size 4vcpu 16GB. Initially clone cloud tool and install dremio using helm install dremio_v2 .I had changed value.yml file with coordinator memory 4096 count 0 and volume 5gb…executor count 1 volume 5gb and mem 4096 and zk count 1 count 1…when installed using helm I saw pods dremio-master-0 ,dremio executor-0 ,zk.total 3 pods and dremio client also running. When I describe dremio client svc I can see loadbalancer with external ip and port 9047.but I am not able to see anything while opening that external ip in browser…

Is the pod count 3 what I got is correct?or do we need another coordinator for webapp…do you find any possible reason why I am not able to view web page.
I didn’t find any issues with vent inbound rules also…

@ann What does the kubectl logs say?


I saw below when i get master logs
10.0..196 - - “GET / HTTP/1.1” 200 2592 “-” “kube-probe/1.21”
c.d.sabot.rpc.user.UserRPCServer - [USER]: Channel closed /10.0.
.199:31010 <–> /10.0..196:21469 (user client)
WARN c.d.e.s.o.SessionOptionManagerFactoryImpl - Could not find session with sessionId 05f4230c-f604-4d21-95f0-7e80474bcdc0.
INFO com.dremio.ConnectionLog - [05f4230c-f604-4d21-95f0-7e80474bcdc0] Connection Closed
.196 - - [04/Oct/2021:05:50:20 +0000] “GET / HTTP/1.1” 200 2592 “-” “kube-probe/1.21”

I have created AKS with advance networking(CNI) as we were not supposed to create our own vnet.

@ann These are not messages that causes master coordinator to not come up. Can you please provide the entire kubectl logs since startup?

For me master coordinator, executor and zk is up and running… Load balancer show external IP too .We have some company policy by which i cannot post entire logs… Let me check what can I give.

@ann Are you able to connect from a JDBC/OBDC tool and see if that works?

I tried connecting using Dbeaver with External Ip provided by loadbalancer… But I need password and username. With some default value it giving connection time out.

also conatiner logs show:
Readiness probe failed: Get "http://10.0..203:9047/": dial tcp 10.0..203:9047: connect: connection refused

@ann From the Master pod, are you able to get a response back for telnet localhost 9047 or does netstat -an | grep 9047 return that connection is established

I am able to make dremio up…Thankyou for support