Dremio community edition v22 availability

Hi all !
concerning community edition v22, do you have any scheduled date ?
Awaiting UPDATE/MERGE/DELETE DML statements for so long !



currently is ready for download, I’m testing but INSERT clause not yet ready

Thank you Darwin for the information ! (@dacopan)
Very strange for INSERT, as it already worked in v21.
Are you sure to use an iceberg table ?

Yes format table are iceberg in the datasource, also if you see on release notes, insert are not mentioned

Darwin, (@dacopan ), I just tested the 22.0 version, and was able to INSERT INTO. Could you please tell me more on your tests ?

I’ve created CTA with

then tried insert with

@dacopan You are missing comma before second tuple and “VALUES” only needs to be specified once.
See documentation and its sample.

Thank you, Sorry was a stupid mistake

Glad that it also works for you

Happens to the best of us!

p.s. We do have an item in the backlog to improve “Failure parsing the query” error as I have to admit - it is absolutely not helpful.