Elasticsearch6 on AWS cluster health privilege issue

#1

Hi everyone,

I have a problem with Dremio + Elasticsearch.

Dremio —> 2.1.4
ES ----> 6.1.3

Elasticsearch is hosted on AWS. Dremio runs locally.

When I try to add ES DataSource, the system return me this error.

Encountered a problem while executing com.dremio.plugins.elastic.ElasticActions$NodesInfo@426a812a. Cannot gather Elasticsearch nodes information. Please make sure that the user has [cluster:monitor/nodes/info] privilege.

Screenshot below.

I had read that the problem could derive from the non-compatibility of version 6 of ES with Dremio, but the problem should be solved.

Anyone can help me please?!

0 Likes

#2

Hi @NapSim

Although Dremio 2.1 has full support for ES6, we are working on supporting ES6 on AWS. We should have the support by the next few releases (Kindly watch for the release notes)

Thanks
@balaji.ramaswamy

0 Likes

#3

Thank you for your answer! I will look forward to the version with the update for ES6 on AWS

0 Likes

#4

Hi @NapSim ,

We have enhanced Dremio to support elasticsearch on AWS. If this is still a requirement, kindly download our latest version 3.0.5 from https://www.dremio.com/download/, upgrade, test and let us know

Thanks
@balaji.ramaswamy

0 Likes

#5

Hi @balaji.ramaswamy
we are still seeing the same issue as above. We installed Dremio this week (on our personal laptop on windows 10) using docker.
Can you please look into it. Thank you

0 Likes

#6

It worked after using the ip address of the ES server instead of its DNS name

0 Likes