Error while Querying S3 (Parquet / Decimal data type)

Using the following ->


Getting the error ->

Decimal data type is disabled. As of this release decimal data type is a beta level feature and should not be used in production Use option ‘planner.enable_decimal_data_type’ to enable decimal data type

It’s exactly as the error message says: decimal support is still not considered production ready, and is disabled by default. You can enable it by going to Admin > Advanced Settings, and setting the option planner.enable_decimal_data_type to true

Thanks for the quick reply. Where exactly that setting is ?

Does it come under advanced Support ?

if you scroll at the bottom of the page, you will see a section named Dremio Support. Enter the key and click Show to have the setting to appear, and then toggle the value.

What is the key for comunity version

The key is the setting name given by the error message (or in the screenshot above).

Worked. Thanks much. planner.enable_decimal_data_type

1 Like