Not able to connect to elastic search from dremio gui to add data source

I created two docker containers for dremio and elasticsearch, and placed them on bridge docker network. I can curl to elasticsearch. When I connect to elasticsearch from dremio gui for adding data source, it does not connect saying privileged user error.

Encountered a problem while executing com.dremio.plugins.elastic.ElasticActions$NodesInfo@51c7f2a7. Cannot gather Elasticsearch nodes information. Please make sure that the user has [cluster:monitor/nodes/info] privilege.

My curl output in dremio container is fine. If I use same host name in dremio gui, it gives above error.

$ curl
“name” : “3d30ab22567e”,
“cluster_name” : “docker-cluster”,
“cluster_uuid” : “zsKUfE6GQHWdTi—XvHkA”,
“version” : {
“number” : “7.17.5”,
“build_flavor” : “default”,
“build_type” : “docker”,
“build_hash” : “8d61b4f7ddf931f219e3745f295ed2bbc50c8e84”,
“build_date” : “2022-06-23T21:57:28.736740635Z”,
“build_snapshot” : false,
“lucene_version” : “8.11.1”,
“minimum_wire_compatibility_version” : “6.8.0”,
“minimum_index_compatibility_version” : “6.0.0-beta1”
“tagline” : “You Know, for Search”

@ssabat See if the 2 issues that were solved for the same error in this thread is applicable in your case too