Processing Request from Tableau takes forever and crashes

Hello to all the community,

I connected my Dremio account with Tableau following the steps of this tutorial:

I am able to connect to Dremio from the web browser but when I open the connection file from Tableau I get a waiting time of minutes to get the table( It’s small, around 500 MB).

When Tableau finally connects with Dremio I get an error of invalid Username or Password, which is not true because I am logged in in the browser with the same credentials.

I have installed the drivers for Dremio and I can see the connector in Tableau, but it is not working.

Setup specs:
Computer: MacBook Pro
OS: macOS 10.14
Tableau: 2018.2.3
Dremio: web browser

@L.Se is this the error you get?

[Dremio][Drill] (30) User authentication failed. Server message: [30017]User authentication failed (please check the username and password).[Server message was: (1d8b6613-2c93-475f-87af-496756f0a50e) Invalid user credentials, user dremio]

Generic ODBC requires additional configuration. The driver and DSN (data source name) must be installed and configured to match the connection.

Invalid username or password.

If so, please check the credentials again. If this is not the error, could you include it here?

@ben Hi ben,

First of all, thanks a lot for reaching out.

The credentials should be fine because I am connected to Dremio on the browser with zero issues. Also we tried with the account of another user and it returns same error.

Sorry, I was limited in the amount if images that I could add before.

The first weird thing is a really long querying time:

Then, the error I get is this one:

But the user and pass are fine, we checked with different user credentials and same error pops up.


Have you tried clicking the tableau button from the dataset to launch the tableau connection?

This downloads a small .tds file that contains the connection config. Dounle clicking the file will launch tableau with this config.

Hi @kelly,

Thanks a lot for answering.

I clicked on the button on Dremio to download the configuration of the database to Tableau:

The user and pass I use are working on Dremio but they jump as not valid when I enter them when Tableau tries to reach out the db.

I am thinking about permissions at this point. Could be possible that I have access to the database but I don’t have the permission to share it or import it into a different platform? This text give me a hint in that direction when the error pops up.

Thanks a lot

Hi @kelly,

The issue has been solved, the port 31010 was not available in our system for connections. Once permissions were granted everything works smoothly.

Thanks a lot, I learnt a lot during this week :slightly_smiling_face: